Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Reporting seems to be broken
#1
Hi Libreplan community,

My colleague, who uses Libreplan told me, that suddently her reporting is not working properly anymore. There were no config changes made, she told me too.


If I take a look at the catalina.out log file while my colleague is requesting a reporting, I can monitore the following error message:
Code:
Nov 14, 2016 4:43:47 PM org.zkoss.zk.au.http.AuDynaMediar service:141
SEVERE: Failed to load media, /view/z_5wy/yLDP28/js9/0/hoursWorkedPerWorkerReport.pdf
>>org.zkoss.zk.ui.UiException: net.sf.jasperreports.engine.JRException: Image read failed.
>>net.sf.jasperreports.engine.JRException: Image read failed.
>>    at net.sf.jasperreports.engine.util.JRJdk14ImageReader.readImage(JRJdk14ImageReader.java:73)
>>    at net.sf.jasperreports.engine.util.JRImageLoader.loadAwtImageFromBytes(JRImageLoader.java:167)
>>    at net.sf.jasperreports.engine.JRImageRenderer.getImage(JRImageRenderer.java:407)
>>    at net.sf.jasperreports.engine.JRImageRenderer.getOnErrorRendererForImage(JRImageRenderer.java:310)
>>    at net.sf.jasperreports.engine.export.JRPdfExporter.exportImage(JRPdfExporter.java:1381)
>>...

I tried to find the specified file "hoursWorkedPerWorkerReport.pdf" in the servers filesystem, but had no success. Even google does not know anything about this error.

Does anyone has an idea what to do now? Is there a way to fix this issue?

Best Regards,

rocket
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)